NolaPro can import the following from MS Office Accounting;:

e Customers

¢ Employees

e General Ledger Totals
e Inventory Categories
e Inventory Items

e Vendors

This information will first need to be exported from MS Office Accounting to Excel and then
saved as a CSV file. This guide provides more information on CSV files as well as instructions to
import into NolaPro.

Building Comma-Separated Files

Many software programs are able to "read"” (better known as import) information if the values
are separated by commas. This is known as a Comma-Separated Values (CSV) file. Building one
of these files by type in each one of the values followed by a comma can be daunting task even
for an accomplished typist.

Here are a few suggestions for building a CSV file so you can import the information into
NolaPro.

Building the File from a Different Software Package

If your software has this feature, export or extract the information into a comma-separated file
format. Many times this option is not available, so if you can copy the information into a
spreadsheet program, such as Microsoft Excel®, this will allow you to easily build the file.

Working with the Information before Importing

To easily work with the data before you import, it is recommended to view and edit the data in a
spreadsheet program, such as Microsoft Excel®. Follow the recommendations below to easily
proofread your data before importing into NolaPro.

1. Open the CSV file in the spreadsheet program or copy and paste the information into a
blank spreadsheet.

2. Enter Headings in the first row of the spreadsheet immediately above the first row of
data. Insert a header row at the top (if not already there), making sure all requested fields
have a heading if the field is empty. An example would be an import for the Chart of



Accounts. See the Ledger -> Setup-Ledger -> Import Accounts screen for more

information.

Account Number Description Type Old ID
1001 Petty Cash Asset A100
1002 Checking Account Asset A200

3. If you have unusual characters in your data such as end-of-record characters or other
hidden characters, you can do the following to easily "clean up" the information.

a. Inablank column to the right of the last colum, insert the following formula on
the second row, =clean(B2)&™"' (assuming column B is the data with the
characters that need removed)

b. Copy this formula down the entire list of entries.

c. Highlight all the entries in the new column and select Edit -> Copy (or Ctrl-C in a
Windows environment.

d. Highlight all of the entries in the column referenced in the formula (column B in

this example). Select Edit -> Paste Special -> Values.

e. Delete the column to the far right you created.

4. Remove Quote Marks From Within Text Fields

5. Monetary Columns Should Not Contain Monetary Symbol or commas in thousands

positions.

You can also do a Find and Replace in most spreadsheet programs to eliminate troublesome
characters such as quotes within a text field.

1. Save the file as a CSV file format (File -> Save As, changing the file Type to CSV). This

file should now be ready to bring into NolaPro.




Import Customers
This utility allows you to import your customers from another application via a comma-
separated (CSV), a tab-delimited, or a pipe(])-delimited file. Follow the restrictions noted in red
and place the fields in the order shown below.

1. From the Main Menu, select Admin -> Imports -> Import Customers.

2. Your screen should look similar to this:

@ Import Customers - Select Customer File

URL File For CSV Format Items: Browse... |
Field Separator comma(,) ~
Text Delimiter Quote Marks (") ~
Full Import: Partial-No Delete -

¥
Import

Remove Quote Marks From Within Text Fields
Replace Commas Within Text with Tilde(~)
Monetary Columns Should Not Contain Monetary Symbol

Customer File Column Format

. Company Name
. Salutation
. First Name
. Middle Name
Last Name
. Suffix
. Address Line 1

8. Address Line 2

9. City

10. State (Abbreviation)
11. Zip

12. Country

13. Phone 1

14. Phone Comment 1
15. Phone 2

16. Phone Comment 2
17. Phone 3

18. Phone Comment 3
19. Phone 4
20. Phone Comment 4
21. E-mail 1

22. Email Comment 1
23. E-mail 2

24. Email Comment 2
25. Website

26. Federal ID

27. Mail Stop

28. Salesman Name

29. Service Rep Name
30. Customer Code Number
31. Invoice Terms

32. GL Sales Account
33. GL Sales Account Description
34. Tax Exemption Reason
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3. URL File For CSV Format Items: Enter the path to the file you would like to import.
You can either manually type the file path or click the Browse button to find an outside
source.

4. Field Separator: Select how the fields are delimited from the drop-down list.

5. Text Delimiter: Select between text surrounded by quote marks, and no quotes around
text fields.

6. Full Import: Choose whether the records being imported are to replace anything
currently in the system, or whether they are a partial import -- which will not delete any
existing data. NOTE: A Full Import will delete ALL customer data for ALL Companies.

!
7. To import the file, click the Import 4 'button.

NOTE: The order of the fields to be imported, and which fields are to be imported will depend
on certain settings in your system. For this reason, be sure to follow your ON-SCREEN
information as to fields and order of fields.



Import General Ledger Totals

Import your current General Ledger Balances from another software package via a comma-
separated (CSV), a tab-delimited, or a pipe(])-delimited file. Place the fields in the order shown

below.

1. From the Main Menu, select Admin -> Imports -> Import GL Totals.

2. Your screen should look similar to this:

& || select GL Balances File

URL File For CSV Format Items: { Browse...

Field Separator comma(,) ~
Text Delimiter Quote Marks (") ~
Full Import: Partial-No Delete v
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Import

Remove Quote Marks From Within Text Fields
Replace Commmas Within Text with Tilde(~)
Monetary Columns Should Not Contain Monetary Symbol

GL Account File Column Format

Date (yyyy-mm-dd)

GL Account Number (1000, 75000, 1234-1)
Debit Amount (if debit, credit amt should be 0)
Credit Amount (if credit, debit amt should be 0)
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3. URL File For CSV Format Items: Enter the path to the file you would like to import.
You can either manually type the file path or click the Browse button to find an outside

source.



4. Field Separator: Select how the fields are delimited from the drop-down list.

5. Text Delimiter: Select between text surrounded by quote marks, and no quotes around
text fields.

6. Full Import: Choose whether the records being imported are to replace anything
currently in the system, or whether they are a partial import -- which will not delete any
existing data. NOTE: A Full Import will delete ALL General Ledger Totals for ALL
Companies.
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7. To import the file, click the Import £ 'button.

NOTE: The order of the fields to be imported, and which fields are to be imported will depend
on certain settings in your system. For this reason, be sure to follow your ON-SCREEN
information as to fields and order of fields.



Import Inventory Categories
Create your Inventory Categories from another application via a comma-separated (CSV), a
tab-delimited, or a pipe(])-delimited file, in preparation for importing Inventory Items into
NolaPro. Follow the restrictions noted in red and place the fields in the order shown below.

1. From the Main Menu, select Admin -> Imports -> Import Inv Categories.

2. Your screen should look similar to this:

Import Item Categories - File

URL File For CSV Format Items: Browse... |

Field Separator comma(,) ~
Text Delimiter Quote Marks (") ~
Full Import: Partial-No Delete v

Import

Remove Quote Marks Fromn Within Text Fields
Replace Commrnas Within Text with Tilde(~)
Monetary Columns Should Mot Contain Monetary Syrnbol

Item Category File Column Format

. Category ID

. Category Name

Blank Field

Season 1 Name

. Season 1 Begin Month Number
. Season 1 End Month Number

. Season 2 Name

. Season 2 Beqgin Month Number
. Season 2 End Month Number
10. Season 3 Name

11. Season 3 Begin Month Number
12. Season 3 End Month Number
13. Season 4 Name

14, Season 4 Begin Month Number
15. Season 4 End Month Number

WAL WO

3. URL File For CSV Format Items: Enter the path to the file you would like to import.
You can either manually type the file path or click the Browse button to find an outside
source.



4. Field Separator: Select how the fields are delimited from the drop-down list.

5. Text Delimiter: Select between text surrounded by quote marks, and no quotes around
text fields.

6. Full Import: Choose whether the records being imported are to replace anything
currently in the system, or whether they are a partial import -- which will not delete any
existing data. NOTE: A Full Import will delete ALL category data for ALL Companies.
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7. To import the file, click the Import = button.

NOTE: The order of the fields to be imported, and which fields are to be imported will depend
on certain settings in your system. For this reason, be sure to follow your ON-SCREEN
information as to fields and order of fields.



Import Inventory Items

Bring your Inventory Items into NolaPro from another application via a comma-separated
(CSV), a tab-delimited, or a pipe(])-delimited file. Follow the restrictions noted in red and place
the fields in the order shown below.

WARNING: The following steps must be completed before running this utility:

o Set Default Inventory Location in Inventory -> Setup-Inventory -> Standard GL
Accounts.

o Set Default Price Level in Inventory -> Setup-Inventory -> Standard GL Accounts.

e Run Import Item Categories

1. From the Main Menu, select Admin -> Imports -> Import Inventory Items.
2. Your screen should look similar to this:

Import Items - File

URL File For CSV Format Items: Browse...
Field Separator comma(,) ~
Text Delimiter Quote Marks (") ~
Full Import: Partial-No Delete
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Import
Set Default Location and Default Price Level in Inventory § tpzt ndard GL Accounts Before Updating
IFDfu\rA NN:ttthL + n and P \Fcudwna Updrd

Remove Quote l\ k F romn Within Text Fields
Re p\ace ommn ithin Text with Tld (~)
Monetary Colu h u\d N »t Contain Monetary Symbol

Item File Column Format

1. Itemcode

2. Category Name

3. Description

4. Stock Unit Name

S. Price Units per Stock Unit
6. Price Unit Name

7. Sales GL Account

8. Inventory GL Account

9. Quantity On-Hand

10. Price At Level: Retail

11. Price At Level: Wholesale
12. Price At Level: Government
13. Price At Level: Education
14. Price At Level: Waste Price
15. Price At Level: MarkDown
16. Price At Level: Wholesale Mark Down
17. Average Cost Each

18. Last Cost Each

19. Taxable(Y/N)

20. Manufacturer

21, Default Vendor Name

22. Reference ID

23. Catalog Description

24, Graphic URL

25, Location Name

26. On Shopping Cart {(1=Yes)
27. UPC Code or ISBN Number
28. Author

29, Front Page (1=Yes)
30. Notes

31. Weight




3. URL File For CSV Format Items: Enter the path to the file you would like to
import. You can either manually type the file path or click the Browse button to
find an outside source.

4. Field Separator: Select the delimiter (comma, Tab, or Pipe(])) that separates the
values in your file.

5. Text Delimiter: Select how Text fields are marked in your file. For example, are
long descriptions enclosed in Quote Marks or not enclosed?

6. Full Import: Select a Full Import (this will DELETE all existing items for ALL
Companies) or a Partial Import (this will UPDATE the existing items).
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7. To import the file, click the Import 4 'button.

NOTE: The order of the fields to be imported, and which fields are to be imported will
depend on certain settings in your system. For this reason, be sure to follow your ON-
SCREEN information as to fields and order of fields.



Import Vendors

Import your vendors via a comma-separated (CSV), a tab-delimited, or a pipe(])-delimited file.
Place the fields in the order shown below.

1. From the Main Menu, select Admin -> Imports -> Import Vendors.

2. Your screen should look similar to this:

¥ @’ Import Vendors - Select Vendor File

URL File For CSV Format Items: [ Browse..
Field Separator comma(,) ~
Text Delimiter Quote Marks (") ~
Full Import: Partial-No Delete -

Import

Remove Quote Marks From Within Text Fields
Replace Commas Within Text with Tilde(~)
Monetary Columns Should Not Contain Monetary Symbol

Vendor File Column Format

1. Company Name
2. Salutation
3. First Name
4. Middle Name
5. Last Name
6. Suffix

7. Address Line 1

8. Address Line 2

9. City

10. State

11. Zip

12. Country

13. Mail Stop

14. Phone 1

15. Phone Comment 1

16. Phone 2

17. Phone Comment 2

18. Phone 3

19. Phone Comment 3

20. E-mail

21. Email Comment

22. Order From Company Name
23. Order From Attn

24. Order From Address Line 1
25. Order From Address Line 2
26. Order From City

27. Order From State

28. Order From Zip

29. Order From Country

30. Order From Mail Stop

31. Order From Phone

32. Order From Phone Comment
33. Order From E-mail

34. Order From Email Comment
35. Customer Account

36. Website

37. Federal ID

38. Verbal Terms

39. Vendor Code

3. URL File For CSV Format Items: Enter the path to the file you would like to import.
You can either manually type the file path or click the Browse button to find an outside
source.



4. Field Separator: Select how the fields are delimited from the drop-down list.

5. Text Delimiter: Select between text surrounded by quote marks, and no quotes around
text fields.

6. Full Import: Choose whether the records being imported are to replace anything
currently in the system, or whether they are a partial import -- which will not delete any
existing data. NOTE: A Full Import will delete ALL vendor data for ALL Companies.
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7. To import the file, click the Import =L button.

NOTE: The order of the fields to be imported, and which fields are to be imported will depend
on certain settings in your system. For this reason, be sure to follow your ON-SCREEN
information as to fields and order of fields.



Import Employees

Import your employees via a comma-separated (CSV), a tab-delimited, or a pipe(|)-delimited
file. Place the fields in the order shown below.

1. From the Main Menu, select Admin -> Imports -> Import Employees.

2. Your screen should look similar to this:

= *ﬁl Import Employees - Select Employee File

URL File For CSV Format Items:

Field Separator comma(,) ~
Text Delimiter Quote Marks (") ~
Full Import: Partial-No Delete A
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Import

Remove Quote Marks From Within Text Fields
Replace Commmas Within Text with Tilde(~)
Monetary Columns Should Not Contain Monetary Symbol

Employee File Column Format

. First Name and Middle Initial

Last Name

. Social Security Number

. Date of Birth(YYYY-MM-DD)

. Hire date(YYYY-MM-DD)

. Release Date(YYYY-MM-DD)

. Pay Type (H=Hourly, S=Salary)

. Pay Period(W=Weekly, B=Bi-Weekly, S=Semi-Monthly, M=Monthly)
. Pay Per Hour(Or Per Period, If Salaried Employee)
10. Date of Last Pay Change(YYYY-MM-DD)
11. GL Expense Account

12. Marital status(S=Single, J=Married Filing Joint, M=Married Filing Separate, H=Head of household)
13. Federal Exemptions

14. State Initials for State Tax

15. State Exemptions

16. Workers Compensation Rate

17. Employee Code

18. Address Line 1

19. Address Line 2

20. City

21. State

22. Zip

23. Country

24, Mail Stop

25. Phone 1

26. Phone Comment 1

27. Phone 2

28. Phone Comment 2

29. Phone 3

30. Phone Comment 3

31. Phone 4

32. Phone Comment 4

33. E-mail 1

34. Email Comment 1

35. E-mail 2

36. Email Comment 2

37. Website

38. Active (TRUE/FALSE)

39. Sick leave hours accrued

40. Vacation hours accrued
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3. URL File For CSV Format Items: Enter the path to the file you would like to import.
You can either manually type the file path or click the Browse button to find an outside
source.

4. Field Separator: Select how the fields are delimited from the drop-down list.

5. Text Delimiter: Select between text surrounded by quote marks, and no quotes around
text fields.

6. Full Import: Choose whether the records being imported are to replace anything
currently in the system, or whether they are a partial import -- which will not delete any
existing data. NOTE: A Full Import will delete ALL employee data for ALL Companies.
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7. To import the file, click the Import =Lbutton.

NOTE: The order of the fields to be imported, and which fields are to be imported will depend
on certain settings in your system. For this reason, be sure to follow your ON-SCREEN
information as to fields and order of fields.



